PyPI/virtualenv CVE-2024-53899: critical 9.8, EPSS 1.57%
virtualenv before 20.26.6 allows command injection through the activation scripts for a virtual environment. Magic template strings are not quoted correctly when replacing. NOTE: this is not the same
Action: Upgrade virtualenv to 20.26.6 or later.
pip install virtualenv==20.26.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 20.26.6 | - |
Fixed versions
| 20.26.6 |
Sources
- osv: PYSEC-2024-187
- https://github.com/pypa/virtualenv/issues/2768
- https://github.com/pypa/virtualenv/pull/2771
- https://github.com/pypa/virtualenv/releases/tag/20.26.6
- https://github.com/advisories/GHSA-rqc4-2hc7-8c8v
CVE-2024-53899 · published · modified · JSON