PyPI/snowflake-connector-python CVE-2024-49750: medium 5.5, EPSS 0.20%
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Prior to version 3.12.3, when the logging
Action: Upgrade snowflake-connector-python to 3.12.3 or later.
pip install snowflake-connector-python==3.12.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.12.3 | - |
Fixed versions
| 3.12.3 |
Sources
- osv: PYSEC-2024-191
- https://github.com/snowflakedb/snowflake-connector-python/security/advisories/GHSA-5vvg-pvhp-hv2m
- https://github.com/snowflakedb/snowflake-connector-python/commit/dbc9284a3c0382c131b971b35e8d6ab93c46f37a
CVE-2024-49750 · published · modified · JSON