PyPI/vyper CVE-2024-24564: medium 5.3, EPSS 0.56%
Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. When using the built-in `extract32(b, start)`, if the `start` index provided has for side effect to update `b`, the byte a
Action: Upgrade vyper to 0.4.0 or later.
pip install vyper==0.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.0 | - |
Fixed versions
| 0.4.0 |
Sources
- osv: PYSEC-2024-205
- https://github.com/vyperlang/vyper/security/advisories/GHSA-4hwq-4cpm-8vmx
- https://github.com/vyperlang/vyper/commit/3d9c537142fb99b2672f21e2057f5f202cde194f
- https://github.com/advisories/GHSA-4hwq-4cpm-8vmx
CVE-2024-24564 · published · modified · JSON