PyPI/vyper CVE-2024-32647: medium 5.3, EPSS 0.46%
Vyper is a pythonic Smart Contract Language for the Ethereum virtual machine. In versions 0.3.10 and prior, using the `create_from_blueprint` builtin can result in a double eval vulnerability when `ra
Action: Upgrade vyper to 0.4.0 or later.
pip install vyper==0.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.0 | - |
Fixed versions
| 0.4.0 |
Sources
- osv: PYSEC-2024-208
- https://github.com/vyperlang/vyper/security/advisories/GHSA-3whq-64q2-qfj6
- https://github.com/vyperlang/vyper/blob/cedf7087e68e67c7bfbd47ae95dcb16b81ad2e02/vyper/builtins/functions.py#L1847
- https://github.com/advisories/GHSA-3whq-64q2-qfj6
CVE-2024-32647 · published · modified · JSON