tocsin

PyPI/waitress CVE-2024-49769: high 7.5, EPSS 1.38%

Waitress is a Web Server Gateway Interface server for Python 2 and 3. When a remote client closes the connection before waitress has had the opportunity to call getpeername() waitress won't correctly

Action: Upgrade waitress to 3.0.1 or later.

pip install waitress==3.0.1

Affected

introducedfixedlast affected
03.0.1-

Fixed versions

3.0.1

Sources

CVE-2024-49769 · published · modified · JSON