PyPI/cryptography CVE-2024-26130: high 7.5, EPSS 0.83%
cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Starting in version 38.0.0 and prior to version 42.0.4, if `pkcs12.serialize_key_and_certificate
Action: Upgrade cryptography to 42.0.4 or later.
pip install cryptography==42.0.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 38.0.0 | 42.0.4 | - |
Fixed versions
| 42.0.4 |
Sources
- osv: PYSEC-2024-225
- https://github.com/pyca/cryptography/security/advisories/GHSA-6vqw-3v5j-54x4
- https://github.com/pyca/cryptography/commit/97d231672763cdb5959a3b191e692a362f1b9e55
- https://github.com/pyca/cryptography/pull/10423
- https://github.com/advisories/GHSA-6vqw-3v5j-54x4
CVE-2024-26130 · published · modified · JSON