PyPI/opencanary CVE-2024-48911: high 7.8, EPSS 0.22%
OpenCanary, a multi-protocol network honeypot, directly executed commands taken from its config file. Prior to version 0.9.4, where the config file is stored in an unprivileged user directory but the
Action: Upgrade opencanary to 0.9.4 or later.
pip install opencanary==0.9.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.9.4 | - |
Fixed versions
| 0.9.4 |
Sources
- osv: PYSEC-2024-248
- https://github.com/thinkst/opencanary/security/advisories/GHSA-pf5v-pqfv-x8jj
- https://github.com/thinkst/opencanary/commit/2c11575b1a3dd8b0df26a879ba856c0aa350c049
- https://github.com/thinkst/opencanary/releases/tag/v0.9.4
CVE-2024-48911 · published · modified · JSON