PyPI/zenml CVE-2024-2260: medium 4.2, EPSS 0.44%
A session fixation vulnerability exists in the zenml-io/zenml application, where JWT tokens used for user authentication are not invalidated upon logout. This flaw allows an attacker to bypass authent
Action: Upgrade zenml to 0.56.2 or later.
pip install zenml==0.56.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.56.2 | - |
Fixed versions
| 0.56.2 |
Sources
- osv: PYSEC-2024-254
- https://huntr.com/bounties/2d0856ec-ed73-477a-8ea2-d5d4f15cf167
- https://github.com/zenml-io/zenml/commit/68bcb3ba60cba9729c9713a49c39502d40fb945e
- https://github.com/advisories/GHSA-g3r5-72hf-p7p2
CVE-2024-2260 · published · modified · JSON