tocsin

PyPI/agentscope CVE-2024-48050: critical 9.8, EPSS 0.81%

In agentscope <=v0.0.4, the file agentscope\web\workstation\workflow_utils.py has the function is_callable_expression. Within this function, the line result = eval(s) poses a security risk as it can d

Action: Upgrade agentscope to 0.0.5a1 or later.

pip install agentscope==0.0.5a1

Affected

introducedfixedlast affected
00.0.5a1-

Fixed versions

0.0.5a1

Sources

CVE-2024-48050 · published · modified · JSON