PyPI/octoprint CVE-2024-23637: medium 4.9, EPSS 0.52%
OctoPrint is a web interface for 3D printer.s OctoPrint versions up until and including 1.9.3 contain a vulnerability that allows malicious admins to change the password of other admin accounts, inclu
Action: Upgrade octoprint to 1.10.0rc1 or later.
pip install octoprint==1.10.0rc1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.10.0rc1 | - |
Fixed versions
| 1.10.0rc1 |
Sources
- osv: PYSEC-2024-29
- https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-5626-pw9c-hmjr
- https://github.com/OctoPrint/OctoPrint/commit/1729d167b4ae4a5835bbc7211b92c6828b1c4125
- https://github.com/OctoPrint/OctoPrint/releases/tag/1.10.0rc1
CVE-2024-23637 · published · modified · JSON