PyPI/ansible-core CVE-2024-0690: medium 5.5, EPSS 0.30%
An information disclosure flaw was found in ansible-core due to a failure to respect the ANSIBLE_NO_LOG configuration in some scenarios. It was discovered that information is still included in the out
Action: Upgrade ansible-core to 2.14.4 or later.
pip install ansible-core==2.14.4pip install ansible-core==2.15.9pip install ansible-core==2.16.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.14.4 | - |
| 2.15.0 | 2.15.9 | - |
| 2.16.0 | 2.16.3 | - |
Fixed versions
| 2.14.4 | 2.15.9 | 2.16.3 |
Sources
- osv: PYSEC-2024-36
- https://access.redhat.com/security/cve/CVE-2024-0690
- https://bugzilla.redhat.com/show_bug.cgi?id=2259013
- https://github.com/ansible/ansible/pull/82565
- https://access.redhat.com/errata/RHSA-2024:0733
- https://github.com/advisories/GHSA-h24r-m9qc-pvpg
CVE-2024-0690 · published · modified · JSON