PyPI/langchain-core CVE-2024-28088: unknown, EPSS 1.74%
LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to control the final part of the path parameter in a load_chain call. This bypasses the intended behavior of loading con
Action: Upgrade langchain-core to 0.1.11 or later.
pip install langchain-core==0.1.11Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.1.11 | - |
Fixed versions
| 0.1.11 |
Sources
- osv: PYSEC-2024-45
- https://github.com/PinkDraconian/PoC-Langchain-RCE/blob/main/README.md
- https://github.com/langchain-ai/langchain/blob/f96dd57501131840b713ed7c2e86cbf1ddc2761f/libs/core/langchain_core/utils/loading.py
- https://github.com/langchain-ai/langchain/pull/18600
- https://github.com/advisories/GHSA-h59x-p739-982c
CVE-2024-28088 · published · modified · JSON