PyPI/django CVE-2024-27351: unknown, EPSS 1.85%
In Django 3.2 before 3.2.25, 4.2 before 4.2.11, and 5.0 before 5.0.3, the django.utils.text.Truncator.words() method (with html=True) and the truncatewords_html template filter are subject to a potent
Action: Upgrade django to 3.2.25 or later.
pip install django==3.2.25pip install django==4.2.11pip install django==5.0.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.2 | 3.2.25 | - |
| 4.2 | 4.2.11 | - |
| 5.0 | 5.0.3 | - |
Fixed versions
| 3.2.25 | 4.2.11 | 5.0.3 |
Sources
- osv: PYSEC-2024-47
- https://groups.google.com/forum/#%21forum/django-announce
- https://docs.djangoproject.com/en/5.0/releases/security/
- https://www.djangoproject.com/weblog/2024/mar/04/security-releases/
- https://github.com/advisories/GHSA-vm8q-m57g-pff3
CVE-2024-27351 · published · modified · JSON