PyPI/django CVE-2024-39329: unknown, EPSS 0.89%
An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. The django.contrib.auth.backends.ModelBackend.authenticate() method allows remote attackers to enumerate users via a timing at
Action: Upgrade django to 4.2.14 or later.
pip install django==5.0.7pip install django==4.2.14Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.2 | 4.2.14 | - |
| 5.0 | 5.0.7 | - |
Fixed versions
| 5.0.7 | 4.2.14 |
Sources
- osv: PYSEC-2024-57
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/forum/#%21forum/django-announce
- https://www.djangoproject.com/weblog/2024/jul/09/security-releases/
- https://github.com/advisories/GHSA-x7q2-wr7g-xqmf
CVE-2024-39329 · published · modified · JSON