PyPI/langchain-experimental CVE-2024-21513: unknown, EPSS 1.89%
Versions of the package langchain-experimental from 0.0.15 and before 0.0.21 are vulnerable to Arbitrary Code Execution when retrieving values from the database, the code will attempt to call 'eval' o
Action: Upgrade langchain-experimental to 0.0.21 or later.
pip install langchain-experimental==0.0.21Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.21 | - |
Fixed versions
| 0.0.21 |
Sources
- osv: PYSEC-2024-62
- https://security.snyk.io/vuln/SNYK-PYTHON-LANGCHAINEXPERIMENTAL-7278171
- https://github.com/langchain-ai/langchain/blob/672907bbbb7c38bf19787b78e4ffd7c8a9026fe4/libs/experimental/langchain_experimental/sql/vector_sql.py%23L81
- https://github.com/langchain-ai/langchain/commit/7b13292e3544b2f5f2bfb8a27a062ea2b0c34561
- https://github.com/advisories/GHSA-cgcg-p68q-3w7v
CVE-2024-21513 · published · modified · JSON