PyPI/django CVE-2024-41990: unknown, EPSS 1.26%
An issue was discovered in Django 5.0 before 5.0.8 and 4.2 before 4.2.15. The urlize() and urlizetrunc() template filters are subject to a potential denial-of-service attack via very large inputs with
Action: Upgrade django to 4.2.15 or later.
pip install django==5.0.8pip install django==4.2.15Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.2 | 4.2.15 | - |
| 5.0 | 5.0.8 | - |
Fixed versions
| 5.0.8 | 4.2.15 |
Sources
- osv: PYSEC-2024-68
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/forum/#%21forum/django-announce
- https://www.djangoproject.com/weblog/2024/aug/06/security-releases/
- https://github.com/advisories/GHSA-795c-9xpc-xw6g
CVE-2024-41990 · published · modified · JSON