PyPI/twisted CVE-2024-41810: medium 6.1, EPSS 1.20%
Twisted is an event-based framework for internet applications, supporting Python 3.6+. The `twisted.web.util.redirectTo` function contains an HTML injection vulnerability. If application code allows a
Action: Upgrade twisted to 24.7.0rc1 or later.
pip install twisted==24.7.0rc1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 24.7.0rc1 | - |
Fixed versions
| 24.7.0rc1 |
Sources
- osv: PYSEC-2024-75
- https://github.com/twisted/twisted/security/advisories/GHSA-cf56-g6w6-pqq2
- https://github.com/twisted/twisted/commit/046a164f89a0f08d3239ecebd750360f8914df33
CVE-2024-41810 · published · modified · JSON