PyPI/mindsdb CVE-2024-45846: high 8.8, EPSS 2.15%
An arbitrary code execution vulnerability exists in versions 23.10.3.0 up to 24.7.4.1 of the MindsDB platform, when the Weaviate integration is installed on the server. If a specially crafted ‘SELECT
Action: Upgrade mindsdb to 24.7.4.1 or later.
pip install mindsdb==24.7.4.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 23.10.3.0 | 24.7.4.1 | - |
Fixed versions
| 24.7.4.1 |
Sources
- osv: PYSEC-2024-77
- https://hiddenlayer.com/sai-security-advisory/2024-09-mindsdb/
- https://github.com/advisories/GHSA-wcjw-3v6p-4v3r
CVE-2024-45846 · published · modified · JSON