PyPI/mindsdb CVE-2024-45850: high 8.8, EPSS 0.87%
An arbitrary code execution vulnerability exists in versions 23.10.5.0 up to 24.7.4.1 of the MindsDB platform, when the Microsoft SharePoint integration is installed on the server. For databases creat
Action: Upgrade mindsdb to 24.7.4.1 or later.
pip install mindsdb==24.7.4.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 23.10.5.0 | 24.7.4.1 | - |
Fixed versions
| 24.7.4.1 |
Sources
- osv: PYSEC-2024-80
- https://hiddenlayer.com/sai-security-advisory/2024-09-mindsdb/
- https://github.com/advisories/GHSA-v6g6-3cm3-vf6c
CVE-2024-45850 · published · modified · JSON