PyPI/keras CVE-2025-1550: critical 9.8, EPSS 2.63%
The Keras Model.load_model function permits arbitrary code execution, even with safe_mode=True, through a manually constructed, malicious .keras archive. By altering the config.json file within the ar
Action: Upgrade keras to 3.8.0 or later.
pip install keras==3.8.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.0.0 | 3.8.0 | - |
Fixed versions
| 3.8.0 |
Sources
- osv: PYSEC-2025-122
- https://github.com/keras-team/keras/pull/20751
- https://towerofhanoi.it/writeups/cve-2025-1550/
- https://github.com/advisories/GHSA-48g7-3x6r-xfhp
CVE-2025-1550 · published · modified · JSON