PyPI/mlx CVE-2025-62608: critical 9.1, EPSS 0.56%
MLX is an array framework for machine learning on Apple silicon. Prior to version 0.29.4, there is a heap buffer overflow in mlx::core::load() when parsing malicious NumPy .npy files. Attacker-control
Action: Upgrade mlx to 0.29.4 or later.
pip install mlx==0.29.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.29.4 | - |
Fixed versions
| 0.29.4 |
Sources
- osv: PYSEC-2025-138
- https://github.com/ml-explore/mlx/pull/1
- https://github.com/ml-explore/mlx/pull/2
- https://github.com/ml-explore/mlx/security/advisories/GHSA-w6vg-jg77-2qg6
CVE-2025-62608 · published · modified · JSON