PyPI/picklescan CVE-2025-10157: high 7.8, EPSS 0.79%
A Protection Mechanism Failure vulnerability in mmaitre314 picklescan versions up to and including 0.0.30 allows a remote attacker to bypass the unsafe globals check. This is possible because the scan
Action: Upgrade picklescan to 0.0.31 or later.
pip install picklescan==0.0.31Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.31 | - |
Fixed versions
| 0.0.31 |
Sources
- osv: PYSEC-2025-153
- https://github.com/mmaitre314/picklescan/blob/2a8383cfeb4158567f9770d86597300c9e508d0f/src/picklescan/scanner.py#L309
- https://huggingface.co/iluem/linux_pkl/resolve/main/asyncio_asyncio_unix_events___UnixSubprocessTransport__start.pkl
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-f7qq-56ww-84cr
CVE-2025-10157 · published · modified · JSON