PyPI/picklescan CVE-2025-1944: medium 6.5, EPSS 0.33%
picklescan before 0.0.23 is vulnerable to a ZIP archive manipulation attack that causes it to crash when attempting to extract and scan PyTorch model archives. By modifying the filename in the ZIP hea
Action: Upgrade picklescan to 0.0.23 or later.
pip install picklescan==0.0.23Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.23 | - |
Fixed versions
| 0.0.23 |
Sources
- osv: PYSEC-2025-20
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-7q5r-7gvp-wc82
- https://sites.google.com/sonatype.com/vulnerabilities/cve-2025-1944
- https://github.com/mmaitre314/picklescan/commit/e58e45e0d9e091159c1554f9b04828bbb40b9781
CVE-2025-1944 · published · modified · JSON