tocsin

PyPI/ray CVE-2025-1979: medium 6.4, EPSS 0.20%

Versions of the package ray before 2.43.0 are vulnerable to Insertion of Sensitive Information into Log File where the redis password is being logged in the standard logging. If the redis password is

Action: Upgrade ray to 2.43.0 or later.

pip install ray==2.43.0

Affected

introducedfixedlast affected
02.43.0-

Fixed versions

2.43.0

Sources

CVE-2025-1979 · published · modified · JSON