tocsin

PyPI/cbor2 CVE-2025-64076: high 7.5, EPSS 0.49%

Multiple vulnerabilities exist in cbor2 through version 5.7.0 in the decode_definite_long_string() function of the C extension decoder (source/decoder.c): (1) Integer Underflow Leading to Out-of-Bound

Action: Upgrade cbor2 to 5.7.1 or later.

pip install cbor2==5.7.1

Affected

introducedfixedlast affected
05.7.1-

Fixed versions

5.7.1

Sources

CVE-2025-64076 · published · modified · JSON