tocsin

PyPI/llama-index CVE-2025-3108: high 7.5, EPSS 0.50%

A critical deserialization vulnerability exists in the run-llama/llama_index library's JsonPickleSerializer component, affecting versions v0.12.27 through v0.12.40. This vulnerability allows remote co

Action: Upgrade llama-index to 0.12.41 or later.

pip install llama-index==0.12.41

Affected

introducedfixedlast affected
0.12.270.12.41-

Fixed versions

0.12.41

Sources

CVE-2025-3108 · published · modified · JSON