PyPI/llama-index CVE-2025-3225: high 7.5, EPSS 0.48%
An XML Entity Expansion vulnerability, also known as a 'billion laughs' attack, exists in the sitemap parser of the run-llama/llama_index repository, specifically affecting version v0.12.21. This vuln
Action: Upgrade llama-index to 0.12.29 or later.
pip install llama-index==0.12.29Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.12.21 | 0.12.29 | - |
Fixed versions
| 0.12.29 |
Sources
- osv: PYSEC-2025-250
- https://github.com/run-llama/llama_index/commit/4f6ee062b19212106a2632af9c9521fc7f0a3584
- https://huntr.com/bounties/e33c0699-e9a2-49aa-837b-5363205637a2
CVE-2025-3225 · published · modified · JSON