PyPI/snowflake-connector-python CVE-2025-24793: high 7, EPSS 0.31%
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vul
Action: Upgrade snowflake-connector-python to 3.13.1 or later.
pip install snowflake-connector-python==3.13.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.2.5 | 3.13.1 | - |
Fixed versions
| 3.13.1 |
Sources
- osv: PYSEC-2025-26
- nvd: CVE-2025-24793
- https://github.com/snowflakedb/snowflake-connector-python/security/advisories/GHSA-2vpq-fh52-j3wv
- https://github.com/snowflakedb/snowflake-connector-python/commit/f3f9b666518d29c31a49384bbaa9a65889e72056
CVE-2025-24793 · published · modified · JSON