PyPI/vyper CVE-2025-27105: critical 9.1, EPSS 0.57%
vyper is a Pythonic Smart Contract Language for the EVM. Vyper handles AugAssign statements by first caching the target location to avoid double evaluation. However, in the case when target is an acce
Action: Upgrade vyper to 0.4.1 or later.
pip install vyper==0.4.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.1 | - |
Fixed versions
| 0.4.1 |
Sources
- osv: PYSEC-2025-31
- nvd: CVE-2025-27105
- https://github.com/vyperlang/vyper/security/advisories/GHSA-4w26-8p97-f4jp
CVE-2025-27105 · published · modified · JSON