PyPI/ironic CVE-2025-44021: low 2.8, EPSS 0.19%
OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can prov
Action: Upgrade ironic to 24.1.3 or later.
pip install ironic==24.1.3pip install ironic==26.1.1pip install ironic==29.0.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 24.1.3 | - |
| 25.0.0 | 26.1.1 | - |
| 27.0.0 | 29.0.1 | - |
Fixed versions
| 24.1.3 | 26.1.1 | 29.0.1 |
Sources
- osv: PYSEC-2025-38
- nvd: CVE-2025-44021
- https://bugs.launchpad.net/ironic/+bug/2107847
- https://security.openstack.org/ossa/OSSA-2025-001.html
- https://github.com/advisories/GHSA-q3m2-crgq-5p3q
CVE-2025-44021 · published · modified · JSON