PyPI/transformers CVE-2025-2099: high 7.5, EPSS 0.61%
A vulnerability in the `preprocess_string()` function of the `transformers.testing_utils` module in huggingface/transformers version v4.48.3 allows for a Regular Expression Denial of Service (ReDoS) a
Action: Upgrade transformers to 4.49.0 or later.
pip install transformers==4.49.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.49.0 | - |
Fixed versions
| 4.49.0 |
Sources
- osv: PYSEC-2025-40
- https://huntr.com/bounties/97b780f3-ffca-424f-ad5d-0e1c57a5bde4
- https://github.com/huggingface/transformers/commit/8cb522b4190bd556ce51be04942720650b1a3e57
- https://github.com/advisories/GHSA-qq3j-4f4f-9583
CVE-2025-2099 · published · modified · JSON