PyPI/django CVE-2025-48432: medium 5.3, EPSS 0.75%
An issue was discovered in Django 5.2 before 5.2.2, 5.1 before 5.1.10, and 4.2 before 4.2.22. Internal HTTP response logging does not escape request.path, which allows remote attackers to potentially
Action: Upgrade django to 4.2.22 or later.
pip install django==5.2.2pip install django==5.1.10pip install django==4.2.22Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.2 | 4.2.22 | - |
| 5.1 | 5.1.10 | - |
| 5.2 | 5.2.2 | - |
Fixed versions
| 5.2.2 | 5.1.10 | 4.2.22 |
Sources
- osv: PYSEC-2025-47
- nvd: CVE-2025-48432
- https://www.djangoproject.com/weblog/2025/jun/04/security-releases/
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/g/django-announce
- http://www.openwall.com/lists/oss-security/2025/06/04/5
- https://github.com/advisories/GHSA-7xr5-9hcq-chf9
CVE-2025-48432 · published · modified · JSON