PyPI/mlflow CVE-2025-52967: medium 5.8, EPSS 0.44%
gateway_proxy_handler in MLflow before 3.1.0 lacks gateway_path validation.
Action: Upgrade mlflow to 3.1.0 or later.
pip install mlflow==3.1.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.1.0 | - |
Fixed versions
| 3.1.0 |
Sources
- osv: PYSEC-2025-52
- nvd: CVE-2025-52967
- https://github.com/mlflow/mlflow/issues/15944
- https://github.com/mlflow/mlflow/pull/15970
- https://github.com/mlflow/mlflow/releases/tag/v3.1.0
- https://github.com/advisories/GHSA-wxj7-3fx5-pp9m
CVE-2025-52967 · published · modified · JSON