tocsin

PyPI/llama-index CVE-2025-6209: high 7.5, EPSS 0.62%

A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the `encode_image` function in `generic_utils.py`. This vulnerability allows an att

Action: Upgrade llama-index to 0.12.41 or later.

pip install llama-index==0.12.41

Affected

introducedfixedlast affected
0.12.270.12.41-

Fixed versions

0.12.41

Sources

CVE-2025-6209 · published · modified · JSON