PyPI/upsonic CVE-2025-6279: high 8, EPSS 0.51%
A vulnerability, which was classified as critical, has been found in Upsonic up to 0.55.6. This issue affects the function cloudpickle.loads of the file /tools/add_tool of the component Pickle Handler
Action: Upgrade upsonic to 0.56.0 or later.
pip install upsonic==0.56.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.56.0 | - |
Fixed versions
| 0.56.0 |
Sources
- osv: PYSEC-2025-68
- https://vuldb.com/?ctiid.313283
- https://vuldb.com/?id.313283
- https://vuldb.com/?submit.593099
- https://github.com/Upsonic/Upsonic/issues/353
- https://github.com/advisories/GHSA-rpfv-46xj-5984
CVE-2025-6279 · published · modified · JSON