tocsin

PyPI/apache-airflow CVE-2025-66388: medium 6.5, EPSS 0.48%

A vulnerability in Apache Airflow allowed authenticated UI users to view secret values in rendered templates due to secrets not being properly redacted, potentially exposing secrets to users without t

Action: Upgrade apache-airflow to 3.1.4 or later.

pip install apache-airflow==3.1.4

Affected

introducedfixedlast affected
3.1.03.1.4-

Fixed versions

3.1.4

Sources

CVE-2025-66388 · published · modified · JSON