PyPI/aiomysql CVE-2025-62611: high 8.2, EPSS 0.39%
aiomysql allows arbitrary access to client files through vulnerability of a malicious MySQL server
Action: Upgrade aiomysql to 0.3.0 or later.
pip install aiomysql==0.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.3.0 | - |
Fixed versions
| 0.3.0 |
Sources
- osv: PYSEC-2026-1110
- nvd: CVE-2025-62611
- https://github.com/aio-libs/aiomysql/security/advisories/GHSA-r397-ff8c-wv2g
- https://github.com/aio-libs/aiomysql/pull/1044
- https://github.com/aio-libs/aiomysql/commit/32c4520dae3711367ded74a4726dcb8bb8919538
- https://github.com/aio-libs/aiomysql
- https://pypi.org/project/aiomysql
- https://github.com/advisories/GHSA-r397-ff8c-wv2g
CVE-2025-62611 · published · modified · JSON