PyPI/apache-airflow CVE-2026-24098: medium 6.5, EPSS 0.83%
Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have
Action: Upgrade apache-airflow to 3.1.7 or later.
pip install apache-airflow==3.1.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.0.0 | 3.1.7 | - |
Fixed versions
| 3.1.7 |
Sources
- osv: PYSEC-2026-12
- http://www.openwall.com/lists/oss-security/2026/02/09/3
- https://lists.apache.org/thread/nx96435v77xdst7ls5lk57kqvqyj095x
- https://github.com/apache/airflow/pull/60801
- https://github.com/advisories/GHSA-5g2w-9f8g-g5q7
CVE-2026-24098 · published · modified · JSON