tocsin

PyPI/apache-airflow CVE-2026-25917: high 7.2, EPSS 0.82%

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly tru

Action: Upgrade apache-airflow to 3.2.0 or later.

pip install apache-airflow==3.2.0

Affected

introducedfixedlast affected
03.2.0-

Fixed versions

3.2.0

Sources

CVE-2026-25917 · published · modified · JSON