tocsin

PyPI/fastapi-guard CVE-2025-53539: high 7.5, EPSS 0.48%

fastapi-guard is vulnerable to ReDoS through inefficient regex

Action: Upgrade fastapi-guard to 3.0.1 or later.

pip install fastapi-guard==3.0.1

Affected

introducedfixedlast affected
03.0.1-

Fixed versions

3.0.1

Sources

CVE-2025-53539 · published · modified · JSON