PyPI/flask CVE-2025-47278: low 1.8, EPSS 0.19%
Flask uses fallback key instead of current signing key
Action: Upgrade flask to 3.1.1 or later.
pip install flask==3.1.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.1.0 | 3.1.1 | - |
Fixed versions
| 3.1.1 |
Sources
- osv: PYSEC-2026-1377
- nvd: CVE-2025-47278
- https://github.com/pallets/flask/security/advisories/GHSA-4grg-w6v8-c28g
- https://github.com/pallets/flask/commit/73d6504063bfa00666a92b07a28aaf906c532f09
- https://github.com/pallets/flask
- https://github.com/pallets/flask/releases/tag/3.1.1
- https://pypi.org/project/flask
- https://github.com/advisories/GHSA-4grg-w6v8-c28g
CVE-2025-47278 · published · modified · JSON