PyPI/llama-index-llms-rungpt CVE-2024-4181: high 8.8, EPSS 2.14%
RunGptLLM class in LlamaIndex has a command injection
Action: Upgrade llama-index-llms-rungpt to 0.1.3 or later.
pip install llama-index-llms-rungpt==0.1.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.1.3 | - |
Fixed versions
| 0.1.3 |
Sources
- osv: PYSEC-2026-1565
- https://nvd.nist.gov/vuln/detail/CVE-2024-4181
- https://github.com/run-llama/llama_index/commit/d73715eaf0642705583e7897c78b9c8dd2d3a7ba
- https://github.com/run-llama/llama_index
- https://huntr.com/bounties/1a204520-598a-434e-b13d-0d34f2a5ddc1
- https://pypi.org/project/llama-index-llms-rungpt
- https://github.com/advisories/GHSA-pw38-xv9x-h8ch
CVE-2024-4181 · published · modified · JSON