tocsin

PyPI/llama-index-readers-obsidian CVE-2025-3046: high 7.5, EPSS 0.64%

LlamaIndex is vulnerable to Path Traversal attack through its ObsidianReader class

Action: Upgrade llama-index-readers-obsidian to 0.5.1 or later.

pip install llama-index-readers-obsidian==0.5.1

Affected

introducedfixedlast affected
00.5.1-

Fixed versions

0.5.1

Sources

CVE-2025-3046 · published · modified · JSON