PyPI/llama-index-readers-papers CVE-2025-3225: high 7.5, EPSS 0.48%
LlamaIndex has an XML Entity Expansion vulnerability in its sitemap parser
Action: Upgrade llama-index-readers-papers to 0.3.2 or later.
pip install llama-index-readers-papers==0.3.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.3.2 | - |
Fixed versions
| 0.3.2 |
Sources
- osv: PYSEC-2026-1570
- https://nvd.nist.gov/vuln/detail/CVE-2025-3225
- https://github.com/run-llama/llama_index/commit/4f6ee062b19212106a2632af9c9521fc7f0a3584
- https://github.com/run-llama/llama_index
- https://huntr.com/bounties/e33c0699-e9a2-49aa-837b-5363205637a2
- https://pypi.org/project/llama-index-readers-papers
- https://github.com/advisories/GHSA-w42r-mrx7-c633
CVE-2025-3225 · published · modified · JSON