PyPI/awslabs-aws-api-mcp-server CVE-2026-4270: unknown, EPSS 0.13%
Improper Protection of Alternate Path exists in the no-access and workdir feature of the AWS API MCP Server versions >= 0.2.14 and < 1.3.9 on all platforms may allow the bypass of intended file access
Action: Upgrade awslabs-aws-api-mcp-server to 1.3.9 or later.
pip install awslabs-aws-api-mcp-server==1.3.9Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.2.14 | 1.3.9 | - |
Fixed versions
| 1.3.9 |
Sources
- osv: PYSEC-2026-162
- https://aws.amazon.com/security/security-bulletins/2026-007-AWS/
- https://pypi.org/project/awslabs.aws-api-mcp-server/1.3.9/
- https://github.com/advisories/GHSA-2cpp-j2fc-qhp7
CVE-2026-4270 · published · modified · JSON