PyPI/mitmproxy CVE-2025-23217: high 8.2, EPSS 0.87%
Mitmweb API Authentication Bypass Using Proxy Server
Action: Upgrade mitmproxy to 11.1.2 or later.
pip install mitmproxy==11.1.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 11.1.2 | - |
Fixed versions
| 11.1.2 |
Sources
- osv: PYSEC-2026-1630
- nvd: CVE-2025-23217
- https://github.com/mitmproxy/mitmproxy/security/advisories/GHSA-wg33-5h85-7q5p
- https://github.com/mitmproxy/mitmproxy/commit/fa89055e196d953f11fd241e36ee37858993486a
- https://en.wikipedia.org/wiki/Server-side_request_forgery
- https://github.com/mitmproxy/mitmproxy
- https://github.com/mitmproxy/mitmproxy/blob/main/CHANGELOG.md
- https://github.com/mitmproxy/mitmproxy/blob/main/CHANGELOG.md#06-february-2025-mitmproxy-1112
- https://pypi.org/project/mitmproxy
- https://github.com/advisories/GHSA-wg33-5h85-7q5p
CVE-2025-23217 · published · modified · JSON