PyPI/jupyterlab CVE-2026-42266: high 8.8, EPSS 5.65%
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed
Action: Upgrade jupyterlab to 4.5.7 or later.
pip install jupyterlab==4.5.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.0.0 | 4.5.7 | - |
Fixed versions
| 4.5.7 |
Sources
- osv: PYSEC-2026-164
- https://jupyterhub.readthedocs.io/en/5.2.1/explanation/websecurity.html
- https://jupyterlab.readthedocs.io/en/latest/user/extensions.html#extension-manager-implementations
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-37w4-hwhx-4rc4
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.7
CVE-2026-42266 · published · modified · JSON