PyPI/apache-airflow CVE-2026-41017: medium 5.9, EPSS 0.35%
Apache Airflow's `JWTRefreshMiddleware` set the JWT auth cookie without the `Secure` flag, so deployments running the Airflow API server behind an HTTPS-terminating reverse proxy (e.g. nginx / Envoy /
Action: Upgrade apache-airflow to 3.2.2 or later.
pip install apache-airflow==3.2.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.0.0 | 3.2.2 | - |
Fixed versions
| 3.2.2 |
Sources
- osv: PYSEC-2026-171
- http://www.openwall.com/lists/oss-security/2026/05/31/6
- https://lists.apache.org/thread/9jx0sk49c1250zflx0q3clc717qgjdch
- https://github.com/apache/airflow/pull/65348
- https://github.com/advisories/GHSA-95v7-h9j5-gvjr
CVE-2026-41017 · published · modified · JSON