PyPI/picklescan CVE-2025-71358: high 8.1, EPSS 0.31%
Picklescan has a missing detection when calling built-in python idlelib.autocomplete.AutoComplete.get_entity
Action: Upgrade picklescan to 0.0.29 or later.
pip install picklescan==0.0.29Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.29 | - |
Fixed versions
| 0.0.29 |
Sources
- osv: PYSEC-2026-1784
- nvd: CVE-2025-71358
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-6w4w-5w54-rjvr
- https://github.com/mmaitre314/picklescan/commit/aecd11be98702caa9ba9b12189d91ad596a36114
- https://github.com/mmaitre314/picklescan
- https://pypi.org/project/picklescan
- https://github.com/advisories/GHSA-6w4w-5w54-rjvr
CVE-2025-71358 · published · modified · JSON