tocsin

PyPI/apache-airflow CVE-2026-30912: high 7.5, EPSS 0.45%

In case of SQL errors, exception/stack trace of errors was exposed in API even if "api/expose_stack_traces" was set to false. That could lead to exposing additional information to potential attacker.

Action: Upgrade apache-airflow to 3.2.0 or later.

pip install apache-airflow==3.2.0

Affected

introducedfixedlast affected
03.2.0-

Fixed versions

3.2.0

Sources

CVE-2026-30912 · published · modified · JSON